How to Increase Mailbox Size in Office 365

Depending on your Microsoft Office 365 plan you can have either a 50GB or a 100GB mailbox size. If you have reached the limit within your plan, then we still have two options. We can either move the mail to the Online Archive or in some cases switch over to a different Office 365 subscription.

Symptom

Mailbox quotas for qualifying license types are not automatically increased to a new default value.

Cause

By design, mailboxes for which an explicit quota was set previously retain that quota instead of having a new default quota applied. This behavior ensures that tenant administrators can set custom quotas for their mailboxes and have them honored by the system.

This behavior can also occur if a different type of license (qualifying for a smaller quota) was originally assigned, and then a new license enabling larger quotas is assigned. Because the original license stamped quota values onto the mailbox, quotas will not be automatically updated when new license values are assigned.

Additionally, several issues that could have caused this behavior have been reported for non-custom quotas for a subset of customers. The resolution for these issues is the same.

Workaround

To work around this issue, use Exchange Online PowerShell to increase mailbox quotas for any mailboxes that do not automatically obtain the updated quotas. For example, you could use the following syntax to assign a 100-GB quota.

PowerShell

Set-Mailbox -Identity<user>-ProhibitSendReceiveQuota 100GB -ProhibitSendQuota 99GB -IssueWarningQuota 98GB

If you have multiple mailboxes that need quota updates, you can make these updates by using the scripting capabilities that are available in PowerShell.

If the previous steps don't update the quotas, make sure that the UseDatabaseQuotaDefaults for the mailbox is set to false:

PowerShell

Set-Mailbox -Identity<user>-UseDatabaseQuotaDefaults:$false

 

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1 The initial archive size is 100GB. When auto-expanding is turned on, the archive will incrementally increase to the max of 1.5TB.

 

Microsoft has increased in the mailbox limitation in the past, in 2013 and later again for the E3 and E5 plans. So if your mailboxes were created before 2016 then it’s possible that your mailboxes still have the old limits, 25Gb instead of 50Gb for Exchange Online plan 1 and 50Gb instead of 100Gb for plan 2.

Also when you have upgraded your Office 365 plan to E3, for example, then the mailboxes may still have the old mailbox size limit.

Checking the current max size

So it’s possible that your mailbox is still assigned an old limit. If that is the case, then we can easily increase the limit of the mailbox within the current plan. We can check the current mailbox size of a mailbox in the Exchange Admin Center:

  1. Open the Exchange Admin Center
  2. Expand Recipients and open Mailboxes
  3. Select the mailbox
  4. Scroll a bit down the view the mailbox size

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We can also use PowerShell to get the mailbox size. Make sure that you have installed the PowerShell Exchange Online Module. We still need to use the old Get-Mailbox cmdlet to view the mailbox limits:

 

# Connect to Exchange Online

Connect-Exchangeonline -userprincipalname [email protected]

 

# Get the mailbox size limits

Get-Mailbox -identity [email protected] | select IssueWarningQuota, ProhibitSendQuota, ProhibitSendReceiveQuota

 

# Get all mailbox sizes

Get-Mailbox | select DisplayName, IssueWarningQuota, ProhibitSendQuota, ProhibitSendReceiveQuota

 

I have also created a PowerShell script that exports all mailbox sizes to Excel. This way you can easily identify mailboxes that still have old limits or mailboxes that are about the run out of space.

Increase Mailbox size Office 365 with PowerShell

Increasing the mailbox size can only be done with PowerShell. You will need to have the Exchange Online Module installed before you can connect to Exchange Online with PowerShell.

We need to set 3 values: 

  • IssueWarningQuota – When the warning is displayed in Outlook
  • ProhibitSendQuota – Determines when the user can’t send mail anymore
  • ProhibitSendReceiveQuota – The user can’t send or receive mail when reached

You want to give the user a warning on time, not when the mailbox limit is reached. So we set the warning to 95Gb. Then prohibit the sending of new mail at 98Gb, so we still have a little room to receive mail until we reach the limit of 100Gb.

# Connect to Exchange Online
connect-exchangeonline -userprincipalname [email protected]
 
# Increase mailbox size
Set-Mailbox -identity [email protected] -IssueWarningQuota 95GB -ProhibitSendQuota 98GB -ProhibitSendReceiveQuota 99GB

 

You can also increase all the mailboxes in one command. If all your users have the same licenses then you can simply run the following PowerShell command to increase mailbox size to 100Gb in Office 365.

Get-Mailbox | Set-Mailbox -identity [email protected] -IssueWarningQuota 95GB -ProhibitSendQuota 98GB -ProhibitSendReceiveQuota 99GB

 

If you have a large tenant with different Microsoft Office 365 plans for your users then you can’t increase all the mailboxes. You could run the command above, but it will throw a lot of errors for all the mailboxes that can’t be changed.

With the command below we get all the user mailboxes (not the shared) and select the mailboxes that have a ProhibitSendReceiveQuota of 50GB. Also, we need to make sure that the user has an Exchange Online Plan 2 mailbox, which we do with BPOS_S_Enterprise. (BPOS_S_Standard is EO Plan 1)

Get-mailbox -Filter {RecipientTypeDetails -eq "UserMailbox"} | 
Where-Object {($_.ProhibitSendReceiveQuota -eq '50 GB (53,687,091,200 bytes)') -and ($_.PersistedCapabilities -contains "BPOS_S_Enterprise")} | 
Set-mailbox -ProhibitSendQuota 98GB -ProhibitSendReceiveQuota 99GB -IssueWarningQuota 95GB

 

Increase Shared Mailbox Size

Shared mailboxes are limited to 50 GB in all Microsoft 365 plans. The advantage of a shared mailbox is that you don’t need to assign a license to it, only the user(s) who access it needs to have an Office 365 license that includes an Exchange Online plan.

To increase the shared mailbox, you will need to assign an Exchange Online Plan 2 license to it. This license will increase the mailbox limit to 100 GB. When you created the shared mailbox, a user account is automatically created in Microsoft 365 with the same name as the shared mailbox.

To assign the license, open the Microsoft 365 Admin Center, look up the mailbox user under Active Users, and assign the license to the user.

Enable Office 365 Online Archive

If you have reached the limits of your Office 365 plan then your only option is to start moving the mail older than 2 years to the Online Archive.

We first have to check if the archive is enabled in the Exchange Admin Center. If you open the mailboxes you will see a column with the Archive Status. If the Archive Status is none then we can enable it.

·  elect the User 

·  Click on Others 

·  Click on Manage Mailbox Archive 

·  Enable the archive

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We can also use PowerShell to enable the Office 365 Online Archive

# Connect to Exchange Online
Connect-ExchangeOnline -userprincipalname [email protected]
 
# Enable the mailbox for John Doe
Get-ExoMailbox -Identity [email protected] | Enable-Mailbox -Archive

 

If you want to enable the archive for all users then use the following PowerShell cmd:

# Connect to Exchange Online
Connect-ExchangeOnline -userprincipalname [email protected]
 
# Enable the Online Archive for all mailboxes
Get-Mailbox -Filter {ArchiveStatus -eq 'none' -and RecipientTypeDetails -eq "UserMailbox"} | Enable-Mailbox -Archive

Retention Tag Policies

We can use retention tag policies (RTP) to move the mail automatically to the archive. By default, there should be an RTP that archives all the mail older than 2 years to the archive.

You can change the policy in the Microsoft Compliance Center (Microsoft Purview):

  1. Expand Data lifecycle management
  2. Open Exchange (legacy)
  3. View or edit the Default MRM Policy

The policy should include a retention tag that moves mail to archive after 2 years:

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etention Tags are assigned to a Retention Policy, which is again assigned to a mailbox. The default retention policy is always assigned to a mailbox if no other policy is assigned. If you want to change the policy then it’s recommended to create a new Retention Policy.

Frequently Asked Questions

What is the Exchange Online plan 1 mailbox size?

The Exchange Online Plan 1 mailbox is 50GB and the size of the online archive is also 50Gb

What is the Exchange Online plan 2 mailbox size?

The Exchange Online Plan 2 mailbox is 100GB and the size of the online archive is by default 100GB and can be increased to 1.5TB

What is the Exchange Online Kiosk mailbox size?

Kiosk mailboxes are only 2GB and don’t come with an online archive. It’s possible to buy the online archive as an add-on.

Can you increase the Office 365 mailbox size over 100GB

No, you will have to use the online archive for this.